• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Perdix AI v65: Old logs show N/A SAC

Discussion in 'Shearwater Research' started by the_ocean, Mar 30, 2019.

  1. the_ocean

    the_ocean Angel Fish

    # of Dives: 100 - 199
    Location: Los Angeles
    47
    15
    8
    Seems like there is a bug in the computer's dive log viewer with the v65 firmware.

    On v53 firmware I was able to view logs on the Perdix AI and see tank pressures and SAC numbers in the log viewer. After upgrading to v65 firmware, the log viewer shows N/A for all items (T1 Start, T1 end, T2 Start, T2 End, AVG SAC T1). This is when viewing old logs (recorded with v53 firmware). I have not tried diving with v65 firmware yet.

    Here is the sequence of things I did:
    1. Upgraded from v53 to v65 using Shearwater Cloud app for Android.
    2. System Setup->Deco Setup: Changed "last stop" from 10 ft to 20ft
    3. System Setup->Bottom Row: Changed Center" from "SurfGF" to Compass (it was set to Compass before the firmware update, but was unexpectedly changed to "SurfGF" after the firmware update.)
    4. System Setup->Log Rate: Changed from 10 sec to 5 sec
    5. View a dive in the dive log.
    I tried setting the Log Rate back to 10 seconds (maybe the old data was being misinterpreted?). Same problem. Tried setting to 2 seconds. Same problem.

    The change log did mention this
    Maybe these calculations are not compatible with old data? Maybe the new data is recorded in a different format in order to support this algorithm?

    I next tried downloaded a log (recorded with v53 firmware) with the Shearwater Cloud android app (perdix AI at v65). The app shows pressure data and correctly calculates SAC.

    (FYI: I normally use the Subsurface android app to download dives from the Perdix. It shows pressure data and calculates SAC correctly for logs produced with v53 firmware. I haven't tried this app with v65 firmware yet. Also have not tried re-downloading my old logs with the new firmware.)
     
  2. Mike1967

    Mike1967 Manta Ray

    # of Dives: 50 - 99
    Location: Victoria, Australia
    522
    171
    43
    I've been talking to Shearwater directly about this and they're working on it.
    No data has been lost, it's just not displaying.


    There's a few posts here about it Firmware Update Cloud - help
     
  3. the_ocean

    the_ocean Angel Fish

    # of Dives: 100 - 199
    Location: Los Angeles
    47
    15
    8
    Good to hear, looking forward to the fix. Good to know the data is still in the logs, just not being displayed. I just ran the Subsurface android app and downloaded an old old log from the Perdix AI with v65 firmware. Pressure data is there and the app calculates SAC with it just fine.

    Sidenote: Subsurface takes a long time to download Perdix AI logs, but it feels like it takes even longer with the new firmware. The v65 firmware release notes had this to say:
    Maybe this resampling process is taking a lot of time? Or maybe Bluetooth LE + Subsurface just don't play nice? I presume my old logs are at 10 seconds anyway, so not sure why this takes so long.
     
  4. Mike1967

    Mike1967 Manta Ray

    # of Dives: 50 - 99
    Location: Victoria, Australia
    522
    171
    43
    Correct ^

    I use Dive Log and I haven't noticed any difference in the download time. Maybe you were more eager than usual to see if your AI data was there so it seemed like it took longer :D
     

Share This Page