IRDA will not work with SmartTRAK on Windows 10.

Please register or login

Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

Benefits of registering include

  • Ability to post and comment on topics and discussions.
  • A Free photo gallery to share your dive photos with the world.
  • You can make this box go away

Joining is quick and easy. Log in or Register now!

Gaztech

New
Messages
1
Reaction score
0
Location
Malta
# of dives
None - Not Certified
Hi guys,

Many users are getting nowhere with this issue.

A friend of mine had the same issue - IRDA dongle not working at all with the SmartTRAK program.

It is essential that you are using the correct version of Windows 10 and the correct dongle driver, otherwise it simply won't work.

I spent a while looking at the problem. I couldn't make it work either - and I've been working with Windows since the very early days. It was unusual to find that nothing worked at all.

I decided to investigate and, once I did get it working, write an "easy to follow" report and post it here. Sorry about the long post but it's necessary to get all the info down.

If you check out the Windows 10 IRDA (infra red) issue online you will see that at some point Microsoft removed the IRDA stack from Windows. This is the code stack that lets Windows use IRDA. It was removed either as a mistake or an error on the part of MS. Either way it was now gone so after doing that all IRDA stuff simply stopped working.

After many people complained - or MS realised the mistake, it was put back into Windows 10.

NOTE: Later versions now have the correct code so that IRDA will now work. Updates from the latter part of 2019 now include the required code.You must have the latest Windows updates for the IRDA to work properly.

However, since they removed it and then put it back, Windows updates now don't really work properly in relation to the hardware getting the correct drivers installed. Generally, the wrong one gets installed or a "generic" driver gets installed. It's as though the detection now doesn't work as it should..

In my case, none of the drivers available from ScubPro worked, neither did the MS default one - so I took the IRDA adapter itself apart to see which comms chip it was using. There, stamped on the chip was "SigmaTEL".

This was an immediate clue. I didn't have any Sigma drivers in any of the driver files I had. None were available from ScubaPro either.

For those of you that have had no success at all getting the Infra red adapter to work, it's very likely that you too have a Sigma comms chip in your adapter. They are quite common and if you've had no joy with anything else you might just get some if you use the official Sigma driver.

I did some Google searching and found this...

SigmaTEL Drivers Location

Go to:

SigmaTel USB-IrDA Dongle (other devices) drivers for Windows

On this page, go to the respective "DOWNLOAD DRIVERS" link for your system. The button/link is shown very clearly on the page.

Download either the 32 or 64 bit driver depending on your operating system. Most users will probably have the 64 bit one but it may be worth downloading both just in case.

When downloaded, create a folder on your desktop called "Sigma". Go to your downloads folder and find the zipped driver file you just downloaded.

Unzip the files into your desktop "Sigma" folder. You'll need something like "Express Zip", "WinRar" or "7Zip" to unpack the file archive. If you're not sure how this works, get one of these programs (use Google - they are all free or limited use free versions which will work). Install the program, then double click on the .zip archive in your "Downloads" folder to open the driver files archive (pick the 64bit one to start off with). Your newly installed zip program will open a window that shows all the files contained in the zip achive.

Highlight all the files that are listed in the zip program window and simply drag and drop them into your new "Sigma" folder on your desktop.

Put the IRDA dongle into the USB port. Now go to device manager and find the IRDA adapter that Windows found in the list - it usually finds it, but loads the incorrect driver. You will probably see the adapter sitting there with a ! mark next to it. Right-Click on the adapter and choose UPDATE Driver.

Choose the "Browse my computer" option, select the Desktop\Sigma folder that you just created and press OK.

If you have a Sigma chip in your dongle (it's very likely, if all the other drivers have failed) then the driver will install. If successful, you will see "installing" and a progress bar. If it does that then we're in with a chance to get it to work. If it fails completely you do NOT have a Sigma chip in your dongle. Game over. You will need to try something else.

When installed, reboot your computer.This is necessary!

Once booted, try the adapter with SmartTRAK and your dive computer. If it works, great - but if it doesn't (you see the adapter IR window come up in the program but no data is downloaded), close the program and go back to Device Manager.

Right click on the IRDA adapter and go to driver properties. Find the tab that lists the NAME of the adapter. You will see that one is already selected (usually also marked with "Default"). Now change the name in the drop down list to the next SIGMA driver in the drop down list, accept your choice and close the window down.

Now try your IRDA adapter again to see if it works. If you find it STILL doesn't work then try the third item in the drop down list and re-try.

If your dongle has a Sigma chip in it then one of these options will make it work.

If it works - it was easy huh? :eek:)

Happy hunting...
 

TerryC

Contributor
Messages
223
Reaction score
130
Location
St Kitts, West Indies
# of dives
2500 - 4999
Very complete post, thankyou.
Just to add, make a note of the driver you are using as the next windows update is likely to reinstall the wrong driver again.
I have the same problem with an older USB to serial adaptor that i use.
 
https://www.shearwater.com/products/teric/

Top Bottom