• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Sealife LCD Error

Discussion in 'SeaLife' started by g1138, Apr 20, 2012.

  1. g1138

    g1138 Marine Scientist

    # of Dives: 500 - 999
    Location: Charleston, SC
    3,068
    807
    I have a SeaLife DC 800 that has a problem. I've tried searching the problem and updating the firmware but no dice so far.

    This all started after taking my camera through airport security, not sure if the X-ray machine or TSA jumbled it while I was taking off my shoes and what not.

    The LCD is hazy and shows kinda ultra violet at times. The resulting photos are all washed out green, whether on land or underwater. Manual White balance really shows green even though I white balance on the provided white card.
    Camera worked like a charm for months before my trip.

    Any ideas how to fix this? I got this camera from scuba.com a year ago, so I'd rather deal with Sea Life's repair shop directly if that's the case.

    PICT0015.jpg PICT0016.jpg PICT0103.jpg

    First pic is with Auto white balance, second two are with manual. Last photo was at 25ft, sunny conditions.
    PICT0085.jpg <- The camera briefly cleared up long enough to snap what I was really seeing. But then quickly fussed up again.
     

Share This Page