• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Dive log options for Cobalt computers

Discussion in 'Ocean Concepts' started by RonR, Aug 26, 2019.

  1. RonR

    RonR Dive Equipment Manufacturer

    # of Dives: I just don't log dives
    Location: Washington State
    1,266
    472
    83
    In addition to the somewhat limited Windows only dive log software available directly from Atomic, there are a number of third party programs that directly connect to the Cobalt. We actively support third party dive log developers, and if there are other dive log options I've missed here please let me know. All of these are either free or low cost.
    Cobalt 2 users don't need any special software to update the firmware in their computers. The process is basically like copying a file to a thumb drive.
    Cobalt 1 users do need to install a Mac or Windows program to enable firmware updates. These applications and instructions can be found here: Atomic Aquatics Cobalt Software
     
    Addicted2H2O likes this.
  2. LStewart

    LStewart Regular of the Pub

    # of Dives: 100 - 199
    Location: Knoxville, TN
    71
    15
    8
    I don't see a better place to post this. I can't download my log from my DC to my PC.

    Atomics Aquatics Cobalt 2 (C2) Dive computer - Version # 2.490/4
    Subsurface software - 4.9.3
    Windows PC - Version 10.0.18363 Build 18363

    Downloaded dives from the C2 back in Oct 2019 with no problems. Now it shows an error when trying to download from it.
    I connect the C2 to the PC, enter the USB screen, then press the right button again to select start, the PC dings like it sees the connection. Subsurface errors after I attempt to download dives.

    I've included the Logfile info and a screenshot of the error.

    Subsurface: v4.9.3, built with libdivecomputer v0.7.0-devel-Subsurface-NG (ce6d9896a79afaa82641132e338f8744714c8593)
    ERROR: Failed to open the usb device. [in /win/subsurface/libdivecomputer/src/atomics_cobalt.c:121 (atomics_cobalt_device_open)]

    Subsurface error.png

    Any help is appreciated. Thanks!
     
  3. RonR

    RonR Dive Equipment Manufacturer

    # of Dives: I just don't log dives
    Location: Washington State
    1,266
    472
    83
    The best suggestion I can make it to ask on the SubSurface User Forum. Actually, on checking that forum myself, I see you already have. :wink:

    But for anyone else with SubSurface questions: User Forum | Subsurface

    Are there any incomplete dives in the Cobalt's log? these would show with dashes for dive time. This can happen if, for instance, battery power runs out during a dive.
    Does it say "Connected" on the Cobalt?
    Is there any contamination on the pins of the Cobalt? Sometimes cleaning those pins can help with an iffy connection.

    Just tried this here with the same version of SubSurface and Cobalt with no problem.

    Let us know what you find.

    Ron
     
  4. LStewart

    LStewart Regular of the Pub

    # of Dives: 100 - 199
    Location: Knoxville, TN
    71
    15
    8
    Yes, since I don't yet know which device is the problem I posted in both places. no, there are no incomplete dives in the log. Here's what I've tried since the first post:

    -Noticed I'm not getting the "connected" verification on screen when I get the audible alert on the PC that it has connected.

    Tried different laptop - same result
    tried different cables and adapters - same result
    tried cleaning the pins using an alcohol pad and a toothpick - same result
    Tried different USB port - same result
    tried rearranging the order I connected/started the software - same result
    And to top it off - I tried all these with my wife's identical C2 and got ..... the same result

    Am I missing anything? Does this sound like a Subsurface problem or connection issue?
     
  5. LStewart

    LStewart Regular of the Pub

    # of Dives: 100 - 199
    Location: Knoxville, TN
    71
    15
    8
    looks like the problem has been found. It appears I need a driver for the Cobalt 2. Any suggestions?
     
  6. RonR

    RonR Dive Equipment Manufacturer

    # of Dives: I just don't log dives
    Location: Washington State
    1,266
    472
    83
    There isn't a Cobalt 2 driver- I don't know if SubSurface requires something specific, that would be a question for them. What indicated to you it was a driver issue?

    Since you have the same result with different PC's, adapters, cables, and Cobalts, it seems likely the issue has to do with SubSurface / Windows. Adapters can sometimes break, so that was going to be one of my next questions. My suggestion below will help establish if the adapter(s) are working.

    The green "connected" message being absent indicates that the device is not actually connecting to the PC, despite the bong.

    One thing to try is to see if you can place the Cobalt into "bootloader" mode- by connecting USB through the adapter, then holding the Back and Select buttons down for 11 seconds, until the screen goes dark. If the Cobalt connects, the Bootloader device should appear on your desktop- just eject to reset the Cobalt. If the Cobalt just resets without appearing on the desktop, then there is a problem establishing a connection.

    Try that and let us know what you see.

    -Ron
     
  7. LStewart

    LStewart Regular of the Pub

    # of Dives: 100 - 199
    Location: Knoxville, TN
    71
    15
    8
    Dirk from the Subsurface user forum asked "Does the dive computer show up in the system device manager?" I looked and it does but it shows needing a driver loaded - cobalt snip.PNG

    I'll check your suggestion out now........ Ok, it does show on the desktop when in bootloader mode.

    Is the "connected" alert on the screen related to being connected to the PC or connected to the software?
     
  8. RonR

    RonR Dive Equipment Manufacturer

    # of Dives: I just don't log dives
    Location: Washington State
    1,266
    472
    83
    OK, it's good that Bootloader shows, that pretty much rules out hardware problems.
    "Connected" is displayed after the device enumerates, it shows connecting to the PC, not the software.

    One question- have you ever installed the Atomic dive log program on these PC's? Cobalt Firmware Downloads - Atomic Aquatics
    It is outdated and has issues with Windows 10, but as we recall it did require and install drivers. We are not too familiar with dive log software beyond providing developers with the information they require, and Dirk is definitely the guru when it comes to SubSurface. Here is what we show here, we are not sure where the driver came from.

    Hope this helps

    -Ron


    full.png
     
  9. LStewart

    LStewart Regular of the Pub

    # of Dives: 100 - 199
    Location: Knoxville, TN
    71
    15
    8
    And that was the magic question .... No, I had not loaded the Atomic Dive log program. I followed that link, installed it and the Cobalt 2 showed connected and downloaded to Subsurface right away. Thanks for all your help!!
     
  10. RonR

    RonR Dive Equipment Manufacturer

    # of Dives: I just don't log dives
    Location: Washington State
    1,266
    472
    83
    OK, something to be aware of. I'll have to see if Atomic can put up a notice about installing the Driver on Windows systems. Thanks for letting us know.
    -Ron
     
    LStewart likes this.

Share This Page