• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

Chromebook Dive log

Discussion in 'Basic Scuba Discussions' started by Frackingawesome, May 21, 2020.

  1. dmaziuk

    dmaziuk Regular of the Pub

    6,564
    2,783
    113
    Basically "USB" is an electrical standard. It knows nothing about shape and size of a particular data stream flowing through it. Which is what subsurface needs to know.
     
  2. dmaziuk

    dmaziuk Regular of the Pub

    6,564
    2,783
    113
    Nitpick in Greek: AFAIK it is about host mode that cellphones were not intended to work in, all the way to the wiring. With a cellphone you normally need to start with a special "OTG" cable to connect USB peripherals. It may or may not be the case w/ the Chromebook, I haven't tried.
     
    BlueTrin likes this.
  3. Tom Wanikiba

    Tom Wanikiba NAUI Instructor

    # of Dives: I'm a Fish!
    Location: Colorado Springs, CO
    5
    2
    3
    I hadn't seen the subsurface app before. I have good news, and inconclusive news.

    Suunto Device Support
    According to this post: Google Groups
    The Cobra and my DX is supported by Subsurface DiveLog.

    No Luck, Yet... Testing on my high-end Samsung Chromebook (XE513C24), which I do have the Linux Beta installed...
    A) Install the subsurface-mobile app from the PlayStore and when I plugged my Suunto DX into the USB port with a USB-C adapter the app did not recognize the watch.
    B) Debian install for version Jessie - Downloads | Subsurface but when I tried to download the GPG signature it failed to download. I went ahead and installed the repo and just attempted insecure, but no luck. I have one version up from Jessie (8.0), my chromebook has Debian 9 (Stretch). I'm attempting an upgrade to Debian 10 (Buster) and might give it another go, if I do and am successful I will post the results and how I did it.

    Then I decided to Try on my One-Plus 7T Phone (Android)
    Installed subsurface-mobile app from the PlayStore and plugged in my watch with USB to USB-C adapter.
    It worked! Sweet, so now I can pull all my logs without firing up the Windows computer I bought just for the 3D printer!

    So, the question is @Frackingawesome does your friend have an Android phone and an adapter, either usb-micro to USB or usb-C to USB to connect to the USB cable they use for the Cobra?
    Screenshot_20200524-145716.jpg Screenshot_20200524-145733.jpg Screenshot_20200524-151137.jpg Screenshot_20200524-145803.jpg Screenshot_20200524-151231.jpg
     
    BlueTrin likes this.
  4. BlueTrin

    BlueTrin ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 100 - 199
    Location: London
    1,623
    758
    113
    Wow that’s really good news.

    Thanks for sharing !
     
  5. dirkhh

    dirkhh Barracuda

    # of Dives: 500 - 999
    Location: Portland, OR, USA
    250
    213
    43
    Subsurface maintainer here.
    - we aren't targeting ChromeBooks at all and this is completely untested. I wouldn't expect Bluetooth or USB serial support to work, but don't know either way
    - running a 'real' Linux distro on a ChromeBook will work just fine, with the caveat that we have recently noticed that Debian and Ubuntu no longer are using identical versions of one of the critical libraries that we need - there are reports that at least Buster is, err, busted. It's really straight forward to compile from source and that would still work when you run Debian on your ChromeBook. Or you could run Ubuntu or Fedora or OpenSUSE which all have supported packages
    - on Android all current Suunto dive computers are supported for downloads
     
  6. Frackingawesome

    Frackingawesome Nassau Grouper

    # of Dives: 100 - 199
    Location: Lancaster, Pa
    91
    42
    18
    Thanks so much guys... i will try that as soon as i can get back to him... I honestly had no idea that a usb to cellphone connection would even be possible... it is not quite as soon as a laptop but it will do and it is FREE so that is even better!!!
     
  7. BlueTrin

    BlueTrin ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 100 - 199
    Location: London
    1,623
    758
    113
    I didn’t have an android phone for a while but I think the connector you use to charge them is a micro USB (or maybe a USB-C now ?)
     
  8. divinh

    divinh ScubaBoard Supporter ScubaBoard Supporter

    # of Dives: 100 - 199
    Location: San Francisco
    917
    441
    63
    Older phones use micro-USB and newer ones have switched over to USB-C.

    I have a Dell Venue 8 7000 tablet, which has micro-USB, and a BlackBerry KEYone, which has USB-C. For both, I've gotten USB-OTG cables to download from my dive computers to Subsurface-mobile. I can confirm that both Android devices (Android 5.1 and Android 8.1) will download over USB-OTG with Cressi's PC FTDI interface and Sherwood's cable. (I believe Sherwood's Amphos/Amphos Air cable is also the same as Oceanic's Geo 2.0 cable.)

    Android Devices

    Dell Venue 8 7000 Android 5.1
    BlackBerry KEYone Android 8.1

    Dive Computers

    Cressi Giotto/Leonardo with FTDI PC interface
    Sherwood Vision with cable
    Sherwood Amphos/Amphos Air with cable

    With the latest version of Subsurface-mobile 3.0.7(4.9.4.113), the 2560 x 1600 resolution of the tablet is fully utilized in landscape, giving a desktop-like interface, i.e. see dive list and a dive profile at the same time.

    Screenshot_2020-05-26-19-21-12.png

    Screenshot_2020-05-26-19-25-53.png
     
    d^2b and BlueTrin like this.
  9. dmaziuk

    dmaziuk Regular of the Pub

    6,564
    2,783
    113
    They may need an "OTG" cable as it has the "host mode" wire.
     

Share This Page