TG-6 GPS Data

Please register or login

Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

Benefits of registering include

  • Ability to post and comment on topics and discussions.
  • A Free photo gallery to share your dive photos with the world.
  • You can make this box go away

Joining is quick and easy. Log in or Register now!

Rick Brant

ScubaBoard Supporter
ScubaBoard Supporter
Messages
352
Reaction score
292
Location
San Diego
# of dives
200 - 499
I'm using my TG-6 to record a GPS log with a swimmer on the surface (for coverage). That works fine and I can import the GPS log into a mapping application. At the same time I am having the swimmer take photos at specific locations along the route, and I need the coordinates of those spots. It seems however that the TG-6 does not save the location into the EXIF data. In other words there is no location data on those images. Is that normal? I mean a camera with GPS enabled should definitely be saving the location along with each image -- maybe I am missing something? I am using an EXIF viewer to check the data.
 
I did read that section, thank you. I have the app, but it does not show the complete track that was recorded. If I open the track file from the camera directly I can see the entire thing. Neither method shows any GPS connection to the photos that were taken. I don't see any of the tagged photos as shown in the description for the app. And this ignores the basics -- why isn't the EXIF data just recorded with the images? This is a very basic design element for the camera -- it has GPS, users want to tag photos, they should be tagged. I'm baffled as to why they would put this arcane and useless app in place rather than simply recording the EXIF data.
 
Yes, log was on. As I mentioned above, the log data was recorded and was accurate. The problem is that the location data is not stored in the EXIF data of each photo. Every mobile phone on the planet is able to do this so it is odd Olympus has not figured this out.
 
Seems like this is a problem others have reported, this links has some hints: Olympus TG-6: No Location Data Showing in Observations

some report success in getting it working other not, the main thing is seeing that the GPS symbol on the LCD is not flashing when you take the shot.

also this: Geotagging with Olympus TG5: Olympus Compact Camera Talk Forum: Digital Photography Review which notes you need to enable GPS tagging in the menus, just switching on the log does not do this apparently. Also something about updating AGPS data regularly.
 
Hmm that's interesting, so you need to choose between logging and tagging. I'll try this next time I use the camera, thanks!
 
Hmm that's interesting, so you need to choose between logging and tagging. I'll try this next time I use the camera, thanks!
You can do both - logging is controlled by the switch and tagging is buried in the menus as far as I can tell. Having logging should keep the GPS ticking over so it has lock when you take a shot.
 

Back
Top Bottom