RX100V memory card issue

Please register or login

Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

Benefits of registering include

  • Ability to post and comment on topics and discussions.
  • A Free photo gallery to share your dive photos with the world.
  • You can make this box go away

Joining is quick and easy. Log in or Register now!

OTF

Coney Island Whitefish Biologist
ScubaBoard Supporter
Messages
632
Reaction score
869
Location
scubaboard
# of dives
200 - 499
I love the images my Sony RX100V makes, but I'm at my wits end with an error it throws. Wondering if anyone else has this issue or any guesses. I should be posting this in a bigger sony forum but thought I'd try scubaboard.

The camera intermittently shows "Unable to read memory card. Reinsert Memory card." at startup. Repeated power cycles and memory card reinsertions occasionally get the camera to start up and work normally for a little while. But the error soon returns. The error happens frequently, but randomly, some days it happens more than others. Obviously I can't mess with the SD card underwater so this is totally debilitating for a dive camera.

Here are some more data points:
  • I paid a respected and certified repair specialist nearly $300 to diagnose and fix the camera, he ended up replacing the entire main board but didn't identify an actual cause. The issue still happened, but happened much less frequently for a month or two after his repair. Then it began happening again as often as before.
  • Sometimes it throws other corrupt data errors or asks if I want to recover card data. After that it will often lock up on a frozen black screen only displaying the shooting mode selection. I guess this happens when the camera freezes up trying to deal with corrupt data?
  • The data is always fine with the card in the computer and other cameras, not showing corrupt data.
  • Formatting the card in the computer, and then in the camera seems to help a little bit, sometimes, but the error warning soon returns.
  • This happens with multiple brands of quality SD cards (Sony and San Disk) that work fine otherwise. I Even tried buying brand new cards to rule out card issues.
  • The camera was never abused or flooded as far as I know, though I shoot with it in a housing underwater so it's possible it experienced some condensation moisture at some point.
  • Appears to be the same problem discussed here: Sony A7 : Unable to read memory card. Reinsert Memory card.: Sony Alpha Full Frame E-mount Talk Forum: Digital Photography Review
Any ideas would be hugely appreciated!
 

OTF

Coney Island Whitefish Biologist
ScubaBoard Supporter
Messages
632
Reaction score
869
Location
scubaboard
# of dives
200 - 499
Also, does anyone know if the older or newer RX100 models will fit in the mk5 housing if I abandon the faulty camera for a cheaper replacement or nicer upgrade?
 
https://www.shearwater.com/products/swift/

Top Bottom