Design Issue with Sea & Sea YS-D1

Please register or login

Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

Benefits of registering include

  • Ability to post and comment on topics and discussions.
  • A Free photo gallery to share your dive photos with the world.
  • You can make this box go away

Joining is quick and easy. Log in or Register now!


Reaction score
I just had my main compartment flooded on the 1st check out Dive at Tubbataha last week. I have not dived for 1.5 years and the unit are checked at the water pail for leaks and then power up at 5m with no issue. Then at 15m when I want to shoot something, I noticed there is no LED light on the strobe and saw bubble at the front of the strobe! I though I have screwed up the battery O-ring. Upon surface, i found my batteries and battery compartment are absolutely dry! Water has entered the strobe through the split line of the main compartment.

This strobe is a replacement strobe given by Sea & Sea Japan as the original I bought had firmware issue (intermittent green/red light and can't fire) during a dive trip in 2014. I not being diving regularly and the strobe has only about 30 dives over last 4 years. The dealer who sold me the strobes told me it being sometime (more than 4 years) since I had it and Sea & Sea recommend to service the Strobe every 2 years as per the Manual!!!! Obviously this also mean Sea & Sea is not going to take responsible for this flooding.

My question is YS-D1 and YS-D2 has more or less the same design. How many cases of this has happened?? I don't see this kind of factory sealed flooding on Inon or Ikelite.


  • IQJP4748.JPG
    56.1 KB · Views: 184
  • MDVL4120.JPG
    59.1 KB · Views: 196
Last edited:
It's the button!

I've previously also had 3 YS-01 strobes fail due to main compartment flooding, and turning dirty brown like yours.
2 were replaced under warranty.
My last one was well out of warranty, but had been sat idle for years.
I took the last one apart, and the main compartment oring did not seem to be compromise at all.
What did look like the smoking gun was the Target Light Button.
It's just a 'normal' button like on any uw camera housing, with a single oring around a pin, which i think is stainless steel, but could be the crappier, less desirable, chromed brass (like on original canon housings). This button's pin get amazingly furred up with minerals/salts, unless you've only been diving in snow melt or have been meticulous when rinsing and drying, including blowing out all the water from behind the button. So, when it's furred up, and you press the button underwater, you're pushing the dirty, furred up part of the pin through the oring, and it then leaks... You see this a lot with hard worked housings... especially the Canons, you'll get a few drips appearing in the housing. I'm sure it doesn't need much more than a drip or two to fry the electronic boards inside these strobes.

I've more recently seen a similar thing with a friend's INON S2000, but this leaked through it's rotary dial knob, giving a lovely corroded area just under it on the board. Dead.

And now, i've got my two YS-D1s on my bench, not working in any usable way, as i decided to do some preventative maintenance and disassemble them and clean them, as they had been in storage for quite a while... And I serviced lots of Laptops, housings, etc. so it's familiar work.
They came apart with a bit of work (compared with the S2000, which was delightfully easy, how it should)... There's several layers to it, with screws, standoff posts, nuts for the battery terminals, connectors for all the dials and connectors, etc... But they came apart without any hitches. And sure enough, the buttons were in a dreadful state, the pins were encrusted af and absolutely would have flooded them both if i'd just taken them off for a dive.
The pins cleaned up nice, lightly greased with christo-lube and the strobes reassembled, again, without any hitches... But now, they turn on, and function perfectly in every mode, but ONLY if the Light Level Control Dial is set to MIN (-2)... ARGH! As soon as turn the dial up it powers off. It can only be restarted when the dial is returned to MIN.
Now comes my idiot tax... I had opened up both, as the first was so easy to do, before i tested the first... So now i have both strobes with exactly the same error! What a dullard.
This does look like something needs resetting perhaps... as i have EXACTLY the same fault on both, so it's not like i accidentally shorted something somehow, as it would either be on only one, or the problems would be different...
So does anyone know any hidden 'reset' button, or dial/button combo like on the D2s? Please help!

S&S really need to design their strobes such that they don't flood the main compartments and die! Double orings? magnetic switches? Something, Anything... As we're all fed up with dirty brown, dead strobes!

Top Bottom