• Welcome to ScubaBoard


  1. Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

    Benefits of registering include

    • Ability to post and comment on topics and discussions.
    • A Free photo gallery to share your dive photos with the world.
    • You can make this box go away

    Joining is quick and easy. Login or Register now by clicking on the button

dc500 problem

Discussion in 'The SeaLife Station' started by wdearn, Dec 7, 2008.

  1. wdearn

    wdearn Instructor, Scuba

    # of Dives: 500 - 999
    Location: Plymouth, Massachusetts, United States
    26
    0
    I used the camera today with no problems and the when I turn it on tonight is goes to usb mode...while not connected to anything???
    you can choose pc..printer or pc cam and push ok and no other buttons work..
    any Ideas??
    how do I get into the test mode?
    thanks
     
  2. Former Sealife Employee

    Former Sealife Employee Contributor

    # of Dives: 0 - 24
    Location: New Jersey
    181
    0
    It sounds like you have damage to the USB port on your camera. This is usually caused by corrosion at the port due to water damage. I suggest that you send the camera and housing in to be water pressure tested and we can go from there. PM me with your full name and address, and I'll issue you a Return Authorization number for you to reference on the box.
     
  3. bobby-in-mass

    bobby-in-mass Divemaster Candidate

    # of Dives: 100 - 199
    Location: lakeville.mass
    122
    1

Share This Page