Can't bluetooth connect Petrel to M1 Mac

Please register or login

Welcome to ScubaBoard, the world's largest scuba diving community. Registration is not required to read the forums, but we encourage you to join. Joining has its benefits and enables you to participate in the discussions.

Benefits of registering include

  • Ability to post and comment on topics and discussions.
  • A Free photo gallery to share your dive photos with the world.
  • You can make this box go away

Joining is quick and easy. Log in or Register now!

USFpsychDiver

Contributor
Messages
241
Reaction score
103
Location
Tampa
# of dives
500 - 999
I recently upgraded my MacBook to an M1 MacBook Pro and I can no longer connect my Petrel to the Mac via bluetooth. I open Bluetooth preferences on the Mac, select "Start Bluetooth" on the Petrel, the Petrel shows up on the Mac Bluetooth list with a "connect" button, I click the button on the Mac and it brings up a passcode requester on the Mac that reads "Enter the code shown on "Petrel" to connect it to this Mac" with a field to enter a 4-digit code. If I leave it blank or enter "0000" it shows connected for a few seconds, then disconnects. If I try to reconnect it shows again as connected for a few seconds, then disconnects reading either "Not Connected" or "Connection Rejected". Never had this issue on my Intel Mac, and I have two Petrels both of which do the same thing. I have a support request in with Shearwater and hopefully it will get resolved but I suspect a deep Bluetooth issue between Apple and Shearwater that'll take a while to resolve. Thought I'd bring it up here in case anyone here has encountered this issue and resolved it. I've done the standard stuff like restarting the Mac and the Petrel, deleting the Petrel from the Bluetooth list and attempting to re-pair. The Shearwater Bluetooth troubleshooting FAQ suggests zapping the PRAM but M1 Macs don't have zappable PRAM.
 

PietroT

Registered
Messages
7
Reaction score
7
Location
Switzerland
# of dives
100 - 199
I recently upgraded my MacBook to an M1 MacBook Pro and I can no longer connect my Petrel to the Mac via bluetooth. I open Bluetooth preferences on the Mac, select "Start Bluetooth" on the Petrel, the Petrel shows up on the Mac Bluetooth list with a "connect" button, I click the button on the Mac and it brings up a passcode requester on the Mac that reads "Enter the code shown on "Petrel" to connect it to this Mac" with a field to enter a 4-digit code. If I leave it blank or enter "0000" it shows connected for a few seconds, then disconnects. If I try to reconnect it shows again as connected for a few seconds, then disconnects reading either "Not Connected" or "Connection Rejected". Never had this issue on my Intel Mac, and I have two Petrels both of which do the same thing. I have a support request in with Shearwater and hopefully it will get resolved but I suspect a deep Bluetooth issue between Apple and Shearwater that'll take a while to resolve. Thought I'd bring it up here in case anyone here has encountered this issue and resolved it. I've done the standard stuff like restarting the Mac and the Petrel, deleting the Petrel from the Bluetooth list and attempting to re-pair. The Shearwater Bluetooth troubleshooting FAQ suggests zapping the PRAM but M1 Macs don't have zappable PRAM.

Same issue with My MacBook Air (intel chipset).
Did you upgrade your old Mac to Monterey? In my case, I lost connectivity to both my Perdix and my Petrel after the upgrade.

I’m mainly using Subsurface as dive log app. There is a thread in the google support group about this topic and it seems that the issue is mainly due to the Bluetooth implementation in Monterey.

Unfortunately, no solution yet.

BR

Pietro
 
OP
USFpsychDiver

USFpsychDiver

Contributor
Messages
241
Reaction score
103
Location
Tampa
# of dives
500 - 999
Thanks for the tip -- led me to some research and it appears that Monterey has major Bluetooth issues -- I have several devices attached to my M1 Mac via Bluetooth with no problems, but I think the original Petrels, which is what I have, have an older version of Bluetooth that's particularly susceptible to problems. I just installed today's new Monterey update, v12.1, and was hopefully since it was supposed to address some of the Bluetooth issues, but alas, no love. It's a shame because this is the first frustration I've had with a Shearwater product (doesn't sound like it's their fault -- sounds like an Apple issue), but I'm not able to connect my Petrel to my phone either via Bluetooth. Sigh. My latest dives are confined to my dive computer for now.
 

rob.mwpropane

Contributor
Messages
2,869
Reaction score
2,152
Location
Fallston, Maryland
I don't have a MAC, but I've had nothing but problems with the bluetooth stack in my PC and others that I just gave up. Now I just use my phone and download to SW and Subsurface. I've never had issues doing it through mobile.
 

o-ren-ishii

Registered
Messages
5
Reaction score
1
Location
Netherlands
# of dives
1000 - 2499
I don't have a MAC, but I've had nothing but problems with the bluetooth stack in my PC and others that I just gave up. Now I just use my phone and download to SW and Subsurface. I've never had issues doing it through mobile.
Can you tell me which app/workflow you use for that?
The "subsurface-mobile app" or shearwater. And how do you get it from mobile to desktop?
Currently I use a shared .xml file on a cloud drive, works well between desktop and laptop but can't get it to my phone and vice versa.
 

Belzelbub

Contributor
Messages
1,414
Reaction score
1,011
Location
Largo, Florida
# of dives
200 - 499
I recently upgraded my MacBook to an M1 MacBook Pro and I can no longer connect my Petrel to the Mac via bluetooth. I open Bluetooth preferences on the Mac, select "Start Bluetooth" on the Petrel, the Petrel shows up on the Mac Bluetooth list with a "connect" button, I click the button on the Mac and it brings up a passcode requester on the Mac that reads "Enter the code shown on "Petrel" to connect it to this Mac" with a field to enter a 4-digit code. If I leave it blank or enter "0000" it shows connected for a few seconds, then disconnects. If I try to reconnect it shows again as connected for a few seconds, then disconnects reading either "Not Connected" or "Connection Rejected".
I have a Mac and a Perdix. I use both Shearwater Cloud and Subsurface. I’ve never had to actually pair the Perdix to the Mac via Bluetooth preferences. I just put the Perdix in Bluetooth mode, then connect via the app. It usually works, but sometimes doesn’t.

The vast majority of the time, I just use the apps on my iPhone. That always works. Syncs via cloud to the desktop apps, so everything matches.
 

rob.mwpropane

Contributor
Messages
2,869
Reaction score
2,152
Location
Fallston, Maryland
Can you tell me which app/workflow you use for that?
The "subsurface-mobile app" or shearwater. And how do you get it from mobile to desktop?
Currently I use a shared .xml file on a cloud drive, works well between desktop and laptop but can't get it to my phone and vice versa.

I backup the perdix to both the Shearwater app and the Subsurface app on my phone and both sync the PC. I use an android, both apps are in the store.

For the 1st connection I have had to play around with it the bluetooth connection some, sometimes even power cycling both devices, but after the initial connection I don't remember having any real issues.

I did find the download was taking forever and based on the suggestions here on SB turned the sample rate up to ever 4 seconds (I think 4 anyway). So now it doesn't take as long to transfer.
 
https://www.shearwater.com/products/perdix-ai/

Top Bottom